AnsweredAssumed Answered

How to disable fec2 but still have working Ethernet

Question asked by Glenn Vriesman on May 17, 2019
Latest reply on May 19, 2019 by igorpadykov

We are currently trying to change the eth2 pins to i2c pins but we cannot get ethernet working when we disable eth2 (fec2). I have tried moving the mdio node to the fec1 node, but I still can't get it to work. Any suggestions? Also, what does the @1 in ethernet-phy@1 mean?

 

I have the following in my device.dts

/* Disable the second ethernet port and remove the mdio for use in fec1 */
&fec2 {
   status = "disabled";
   /delete-node/ mdio;
};

/* Add mdio to the fec1 node */
&fec1 {
   mdio {
        #address-cells = <1>;
        #size-cells = <0>;

        ethphy0: ethernet-phy@1 {
            compatible = "ethernet-phy-ieee802.3-c22";
            micrel,rmii-reference-clock-select-25-mhz;
            clocks = <&rmii_ref_clk>;
            clock-names = "rmii-ref";
            reg = <1>;
        };

        ethphy1: ethernet-phy@3 {
            compatible = "ethernet-phy-ieee802.3-c22";
            micrel,rmii-reference-clock-select-25-mhz;
            clocks = <&rmii_ref_clk>;
            clock-names = "rmii-ref";
            reg = <3>;
        };
    };
};

Outcomes