AnsweredAssumed Answered

IMX8M EVK can not use serial downloader by USB

Question asked by geng geng on Apr 9, 2019
Latest reply on Apr 26, 2019 by jimmychan

We have a I.MX8MQ EVK board,the version is B4.

It can boot to andriod system with emmc, and the debug usb-serial is well worked.

Now we want to update the system by USB serial downloader, do as the follow:


(1) Switch the bootmode of i.MX8MQ EVK SW802  BOOTMODE[1:0] from 10 to 01.

(2) Connecting J901(USB type-c) to PC USB by a USB 3.0 cable.

(3) Connecting J1701 to PC USB by a USB cable.

(4) Plugging 12V@5A adapter into Power Jack (J902)

(5) Power on I.MX8MQ board via SW701 Switch


We can see that the board is not booting from internal device, because of step 1.

But we can not use uuu or mfgtools to update the system, we have tried both on windows and Ubuntu.

Also we find there is not any HID compaliant device in the host PC.


is the TYPE-C USB serial downloader broken?

is there any methord to fix this problem?


thanks for your replay!