• Bug-Fixes for FlexSPI

    We are using a SoM with an i.MX8M-Mini and tried to use the FlexSPI to communicate with an FPGA which simulates a flash memory using 1-1-4 or 1-4-4 transfer mode. To get that working we had to fix or extend the linux...
    Christoph Fink
    last modified by Christoph Fink
  • AOSP Update

    Hi, I am using iMX8M Mini EVK and AOSP 9.0 version and I am able to run AOSP successfully on my EVK board.   In my current AOSP version AOSP 9.0 I added some custom code in system service layer, JNI layer, HIDL...
    Maneesh Singh
    last modified by Maneesh Singh
  • i.MX8 ov5640_mipi_v3 driver problem - SOLVED

    Solved Edit :  First problem was at hardware. If I load ov5640_mipi_v3 as module I got error. But with build-in there was no problem. I could get video.   -------------------------------------------------...
    berat yildiz
    last modified by berat yildiz
  • How to flash uboot binary on iMX8MQ eMMC using dd command

    I was able to flash the imx8mq uboot binary with uuu but I need to know the equivalent dd command to flash uboot binary to emmc. I successfully flashed uboot environment on emmc with the following command dd if=u-bo...
    Haseeb Ashraf
    last modified by Haseeb Ashraf
  • Android Q10.0.0.1.0.0 for i.MX8 MQ evk

    Hello,   I recently found that NXP has released the proprietary source code for Android 10. Just wanted to starting integrating it with Marvell wireless modules for imx8mq evk. Is it been tested before? Now tha...
    Achyut Hegde
    last modified by Achyut Hegde
  • i.MX8M EVK MIPI CSI Camera Frame Rate

    Hello, We have purchased NXP MIPI-CSI camera MINISASTOCSI kit and followed the instructions in this application note https://www.nxp.com/docs/en/application-note/AN12187.pdf  to test the camera on NXP i.MX8M EVK...
    Felix Radensky
    last modified by Felix Radensky
  • FLEXCAN RXFIFO and Gobal Mask Filter Behaviour Incorrect?

    I have included below snippet of initialization code used with FLEXCAN on the MXRT1064-EVK board with MCUXpresso IDE. We have 19 filters, so there should be 12 filters (0-11) that can be individually masked, and the r...
    Christopher Evans
    last modified by Christopher Evans
  • Yocto qemu-native failure

    Hello,   So I'm trying to build my first yocto image for the imx6sx. I followed the steps in the i.MX Yocto Project User Guide but I've hit an error building qemu-native. I've attached the error log.   Doe...
    Arian Suarez
    last modified by Arian Suarez
  • I.MX8QMax -- How to Compile QT Cpp code

    Hi, How to cross compile simple QT Cpp code for I.MX8QMax. I did below steps   export PATH=/opt/fsl-imx-x11/4.9.51-mx8-beta/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux/:$PATH export CROSS_COMPIL...
    Santhosh Kumar
    last modified by Santhosh Kumar
  • git.freescale.com down

    We noticed this morning our builds started failing. Looks like attempting to clone firmware-imx is failing.   When I try to clone the repo independent of a yocto build I see the following output:   git clo...
    Adam Bader
    last modified by Adam Bader
  • i.Mx8Mini HABV4 Errors

    i.mx8 mini HABv4 I am trying to get HABv4 working on the HABv4 mini.  The system is running Android version 9 and is on the evaluation board.  I have followed the instructions using the User Guide :  ...
    Wendi Whitcomb
    last modified by Wendi Whitcomb
  • Why screenrecord cannot work noramally?

    I take video according shell command "screenrecord --size 1920x720 --time-limit 10 /sdcard/test.mp4", but the video is abnormally, but screencap is normal.
    ming chen
    last modified by ming chen
  • Is there a specific SDK version with TEE applied?

    We want to apply TEE to IMX6. Is there a specific SDK version with TEE applied? Or is it possible to apply TEE in all SDKs regardless of the SDK version?
    kilsoo choi
    last modified by kilsoo choi
  • Imx6q runs GPU program, the picture is stuck

    The GPU picture is stuck and stays in the crystal ball picture; see Figure 1 for details; Check with serial port, there is error message in 5595 subprogram under GPU program, see Figure 2 for details; kill this 559...
    钱委 钱
    last modified by 钱委 钱
  • galcore module failed to load

    Hi all, Currently I'm using toradex_4.9-2.3.x-imx kernel for my Buildroot system and I plan to do some testing on the Vivante GPU using the examples provided by Freescale :    But I've got errors for follow...
    Khang Le Truong
    last modified by Khang Le Truong
  • Receiving junk data while running rs485 send and receive application on imx6dl

    I'm using an imx6dl board with Android BSP.  I'm running a custom application on the board where I configure my Linux PC as a sender and the board a receiver. The PC transmits * Bytes of data at 38400 Baudrate ...
    Sujay S
    last modified by Sujay S
  • iMX6 DualPlus/6QuadPlus

    Hi all  can you please help Is the iMX6 DualPlus/6QuadPlus the right processor for measurement of below parameters? Also I want to go for OS based application that needs to perform other tas...
    abhay Bellale
    last modified by abhay Bellale
  • i.MX8QM yocto use opencv issue

    Hello,   When I used opencv write some code and use Umat function run in yocto OS happened error but it run well on Windows OS. OpenCL error CL_INVALID_WORK_GROUP_SIZE (-54) during call: clEnqueueNDRangeKernel(...
    Xu Ji
    last modified by Xu Ji
  • ADC SyncMode Noise

    We currently face an issue with the i.MXRT1060 that noise is introduced to our ADC measurements whenever we take two measurements concurrently, but is absent when the Measurements are taken one after another.   ...
    Alessandro Forino
    last modified by Alessandro Forino
  • imx6ul

    1. How uboot changes to the new partition when kernel fails to start.   2. kernel changes any boot arguments to notify the uboot ? 
    Srinu inaganti
    last modified by Srinu inaganti