• UIO to handle GPIO interrupts?

    I am hoping that you can provide advice on using UIO to handle an interrupt from user space.  I found an excellent summary at https://yurovsky.github.io/2014/10/10/linux-uio-gpio-interrupt.html and have tried to ...
    Scott Whitney
    last modified by Scott Whitney
  • i.MX8MQ is hanging in busfreq-imx8mq.c driver

    Hi NXP Team,   We are trying to port the i.MX8MQ custom board to Linux kernel 5.4.3. We are using the 5.4.3 kernel provided by the NXP team.   Please note that on the same board, previous version 4.7 is wo...
    Harshit Shah
    last modified by Harshit Shah
  • Build mfgtool firmware uboot

    Hi community, I'm working on the i.MX6 sabresd Quad platform with no PMIC.   While I try to burn image with mfgtool and I received log that show no pmic detected.   So I assumed that I need to build ...
    tsung li wang
    last modified by tsung li wang
  • iMX6 with wm8950 ssi issue

    Hi. I got a problem of wm8950 codec on imx6solo custom board. Here is my dts configuration.       sound {         compatible = "fsl,imx6q-sabresd-wm8950",  ...
    Han Gun Woo
    last modified by Han Gun Woo
  • IMX 8 clock/xtal inputs

    Hi, I am designing the IMX 8 onto a very limited board space so I am trying to restrict any unnecessary components I don't need. we believe the majority of our clocks can be run from the 25Mhz input and the 27Mhz inpu...
    Enoch Arthur
    last modified by Enoch Arthur
  • Syncing Yocto Source to Local git repo

    Hello Team,   I am new to Yocto, I have synced the code for i.mx8DualXplus, But I want to push the Yocto Source code to Local git repository which is maintained by my office on local GitLab server. I have creat...
    kailas kharse
    last modified by kailas kharse
  • Zero copy between GPU and VPU

    I am trying to take physical buffers from the imxvpudec gstreamer element, and modify them using the GPU with GLES and EGL, before passing them to the VPU encoder with imxvpuenc_h264.     For passing the me...
    Erlend Eriksen
    last modified by Erlend Eriksen
  • I need to use l4.9.88_ 2.0.0_ mfg-tool_ Mx8mq to burn my system

    I need to use l4.9.88_ 2.0.0_ mfg-tool_ Mx8mq is used to burn my system, but during the burning process, the card is stuck in uboot. Please don't let me use uuu or. Sacard. I can use both. I just want to use mfgtool2,...
    JCon St
    last modified by JCon St
  • imx8: Facedetection not working with NXP MINISASTOCSI Camera

    I am testing facedetection sample code. Detection is not proper & continuous on face while testing on imx8mq evk target with MIPISASTOCSI camera but the same binary working effectively with less resolution USB web...
    vipul Suneja
    last modified by vipul Suneja
  • How to set external RTC in kernel

    Hi  Some days ago,I asked a question about RTC RTC always reset to 19700101   After investigation, I find it can not register the external RTC (BM8563ESA, I2C RTC) if I close all the on-cpu RTC i...
    铭恒 李
    last modified by 铭恒 李
  • zeus-5.4.24-2.1.0 won't boot on my IMX8MNEVK board

    Hi!   I'm trying to get the 5.4.24-2.1.0 release to run on my IMX8MNEVK board but I get the following error when trying to boot the image:   U-Boot SPL 2020.04-5.4.24-2.1.0+g4979a99482 (Jul 07 20...
    Simon Pettersson
    last modified by Simon Pettersson
  • imx7d using dma to transfer eim data

    Hello everyone my development board is IMX7DSABRE. Linux kernel version is 4.9.88. When I use dma to transmit EIM data to FPGA on imx7d, when I write data to EIM bus, some problems occur. My EIM bus data width is conf...
    其东 刘
    last modified by 其东 刘
  • Why is meta-qt5 in imx-5.4-24-2.1.0 using master branch instead of  zeus

    Hi, we have started to port our Yocto BSP to the latest release imx-5.4.24-2.1.0 and have seen that the meta-qt5 layer points in the manifest to the master branch and not like the rest of the repos to the zeus branch...
    Mike Engel
    last modified by Mike Engel
  • Download u-bootkernel to SD1 on the i.mx6ul EVK

    On i.MX6UL EVK board, it supports many boot device: SD Card(SD1) boot in main board, micro-SD card(SD2) boot in CPU board and others.... I can boot SD1 and SD2 on the i.MX6UL EVK. And mfgtool2 can download u-boot/ke...
    ERICSON CHIEN
    last modified by ERICSON CHIEN
  • IMX6ULL LCD驱动失败提示21c8000.lcdif supply lcd not found, using dummy regulator

    大家好:    我的linux找不到LCD驱动,请问我该怎么解决这个问题。 下面是uboot打印信息 U-Boot 2016.03-svn350(2019年1月10日-17:42:08 +0800) CPU:飞思卡尔i.MX6ULL rev1.1 528 MHz(运行于396 MHz) CPU:52 ° C时的商业温度等级(0C至95C) 复位原因:POR 板:MYIMX6EK140-...
    wentong jia
    last modified by wentong jia
  • IMX6SOLOX processor maximium  supported density for NOR Flash IC

     what is the maximium density supported by IMX6SOLOX processor for NOR flash IC ? 
    Deepa Sharma
    last modified by Deepa Sharma
  • How do i see USB_OTG enabled device files in linux-imx?

    Hi,   I am using yocto sumo version linux kernel.   I enabled the following OTG configuation in menuconfig: /******************************************************** Symbol: USB_OTG [=y] x x Type : bool...
    Anush Deekonda
    last modified by Anush Deekonda
  • How to put bootanimation.zip into the sources

    I have learned how to put bootanimation.zip into /system/media/ on the installed system or e.g. into out/target/product/evk_8mm/system/media/ in the android_build directory.   But how can I put it into the andro...
    a b
    last modified by a b
  • MIPI DSI driven by LCDIF is not working in i.MX8MQ

    I am using Linux 4.14.98 BSP. I'm using panel raydium 67198 which supports 1080p resolution. My display works fine if I use DCSS as input source for MIPI DSI. If I change it to LCDIF, frame buffer is created. But noth...
    Abhishek Hegde
    last modified by Abhishek Hegde
  • IMX8MQuad audio codec

    Hi to All,   I am new in this IMX8MQuad processor. We have an EVK for this IMX8MQuad. If we check audio part, audio codec is not working. But when we tried with hdmi audio its working fine. we checked the fo...
    prathap ponnuchamy
    last modified by prathap ponnuchamy